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C H A P T E R  4

Preinstallation Steps

The first part of this book discussed using Linux as part of your day-to-day life. It was 

intended to help you evaluate Linux and understand what you’re buying into should you 

decide to make it your operating system of choice. Now we move on to actually installing 

Linux and, specifically, Ubuntu, which is included with this book on a DVD-ROM.

Installing any kind of operating system is a big move and can come as something of a 

shock to your PC. However, Ubuntu makes this complicated maneuver as easy as it’s 

possible to be. Its installation routines are very advanced compared to previous versions 

of Linux, and even compared to other current distributions.

What does saying that you’re going to install Ubuntu actually mean? This effectively 

implies three things:

• Somehow, all the files necessary to run Ubuntu are going to be put onto your hard disk.

• The PC will be configured so that it knows where to find these files when it first 

boots up.

• The Ubuntu operating system will be set up so that you can use it. 

However, in order to do all this and get Ubuntu onto your PC, you must undertake 

some preparatory work, which is the focus of this chapter.

Understanding Partitioning
Chances are your PC already has Windows installed on it. This won’t present a problem. 

In most cases, Ubuntu can live happily alongside Windows in what’s called a dual-boot 

setup, where you can choose at startup which operating system to run. However, installing 

Ubuntu means that Windows must make certain compromises. Windows is forced to cohabit 

on your hard disk with another operating system—something it isn’t designed to do.

The main issue with such a situation is that Windows needs to shrink and make some 

space available for Ubuntu (unless you install a second hard disk, which is discussed later 
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in this chapter). Ubuntu isn’t able to use the same file system as Windows, and it needs its 

own separately defined part of the disk, which is referred to as a partition. All of this can 

be handled automatically by the Ubuntu installation routine, but it’s important that you 

know what happens.

All hard disks are split into partitions, which are large chunks of the disk created to hold 

operating systems (just like a large farm is partitioned into separate fields). A partition is 

usually multiple gigabytes in size, although it can be smaller. 

■Note  If you use a Macintosh then don’t feel left out! In the next chapter we include a sidebar explaining 

the options for installing Ubuntu on your computer. 

You can view your disk’s partitions using the Disk Management tool in Windows XP, 

2000, and Vista, as shown in Figure 4-1. You can access this tool by opening the Control 

Panel, switching to Classic View, clicking the Administrative Tools icon, selecting Computer 

Management, selecting Storage, and then choosing Disk Management.

Figure 4-1. You can view your disk’s partitions using Windows’s Disk Management tool.
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Most desktop PC systems have just one partition, unless the user has specifically created 

new partitions. As mentioned, Ubuntu needs a partition of its own. During installation, 

Ubuntu needs to shrink the main Windows partition and create a fresh partition alongside 

it (actually, it creates two partitions; the extra one is used to hold the swap file).

In addition, the Ubuntu installation routine writes a new boot sector (also known as a 

boot loader). The boot sector is located at the very beginning of the disk and contains a small 

program that then runs another program that lets you choose between operating systems 

(and therefore partitions) when you first boot up.

■Note  Not all Linux distributions have the ability to repartition the hard disk. In fact, at the time of writing, 

it’s pretty rare. Most expect to simply take over the entire hard disk, wiping Windows in the process (although 

they’ll always ask the user to confirm this beforehand). The ability to repartition a disk is just one of the reasons that 

Ubuntu is among the best Linux distributions currently available.

Of course, Ubuntu cannot shrink a Windows partition that is packed full of data, because 

no space is available for it to reclaim. 

UBUNTU AND WINDOWS FILE SYSTEMS

One of the benefits of dual-booting Linux and Windows is that Ubuntu lets you access the files on the 

Windows partition. This is quite handy and facilitates the easy exchange of data. 

If the Windows partition is FAT32—used on Windows 95, 98, Me, and (sometimes) XP—then 

Ubuntu can both read and write files to the partition. However, if the file system is NTFS—used with 

Windows NT, 2000, XP, and Vista—Ubuntu will make the file system available as read-only. 

Because of this, if you run Windows XP, you might consider converting your NTFS Windows parti-

tion to FAT32 before you install Ubuntu (but be aware that doing so means you lose some of the security 

and performance features of NTFS). Microsoft doesn’t include a tool that lets you do this automatically, 

but you can use third-party disk partitioning programs like Norton’s Partition Magic (www.

powerquest.com) to convert your file system. 

Freeing Up Space
The first step before installing Ubuntu alongside Windows is to check how much free 

space you have in your Windows partition. To see the amount of free space you have 

under Windows Vista, click the Start button, click Computer, and look at the bar graph 

next to your hard disk drive, as shown in Figure 4-2. With older versions of Windows, you 
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should double-click My Computer, right-click your boot drive, and select Properties. The 

free space is usually indicated in purple on a pie chart. 

In both cases, look for how much free space you have. In Windows Vista, this is the first 

figure underneath the bar graph.

You need to have at least 3GB of free space in your Windows partition for Ubuntu to 

use. You’ll need more space if you wish to install a lot of programs. If you don’t have 

enough free space, you have several options: reclaim space, remove Windows, or use a 

second hard disk.

Figure 4-2. Ubuntu needs free disk space in which to install, so you might need to clean up 

your Windows partition.

Reclaiming Space

In Windows Vista and XP, you can run the Disk Cleanup tool to free some space on your 

hard disk. Under Windows Vista, click Start ➤ Computer, and right-click the icon repre-

senting your hard disk. Select Properties from the menu that appears, and click the Disk 

Cleanup button. On Windows XP, click the Disk Cleanup button beneath the pie chart 
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showing the free disk space. Disk Cleanup is also accessible by clicking Start ➤ All 

Programs ➤ Accessories ➤ System Tools ➤ Disk Cleanup.

You might also consider turning off System Restore. This consumes a lot of disk space, 

which you can therefore reclaim. However, deactivating System Restore will mean that 

you lose the possibility of returning your system to a previous state should anything go 

wrong. To access the System Restore under Vista, click the Start button, and then right-

click Computer in the menu. Select Properties, and click the System Protection link on the 

left of the window that appears. Next, remove the check alongside the drives under the 

Available Disk list, confirm that you want to turn off System Restore, and click the OK 

button on the System Properties dialog box. Under Windows XP, right-click My Computer, 

click Properties, and then click the System Restore tab. Next, put a check alongside Turn 

Off System Restore on all Drives, and click OK. 

If you still cannot free up enough disk space, consider uninstalling unused software via 

the Add/Remove Programs applet within Control Panel. If you have any large games 

installed, consider removing them first, because they usually take up substantial amounts 

of hard disk space. You might also consider deleting movie and MP3 music files, which are 

renowned for eating up hard disk space. The average MP3 is around 4MB, for example, 

and one minute of video typically takes up 1MB of disk space!

Removing Windows

Some users might prefer a second, more radical option: getting rid of Windows completely 

and letting Ubuntu take over the entire hard disk. If you feel confident that Ubuntu will 

fulfill your needs, this is undoubtedly the most straightforward solution. You’ll be able to 

do this during installation. However, this will also mean that any personal data you have 

will be lost, so you should first back up your data (as described shortly).

■Caution  You should be aware that installing Windows back onto a hard disk that has Ubuntu on it is trouble-

some. Windows has a Darwinian desire to wipe out the competition. If you attempt to install Windows on an 

Ubuntu hard disk, it will overwrite Linux.

Using Another Hard Disk

A third option for making room for Ubuntu is attractive and somewhat safer in terms of 

avoiding the potential for data loss, but also potentially expensive: fitting a second hard 

disk to your PC. You can then install Ubuntu on this other hard disk, letting it take up the 

entire disk. Unlike Windows, Ubuntu doesn’t need to be installed on the primary hard 

disk and is happy on a secondary drive.
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A second hard disk is perhaps the best solution if you’re low on disk space and want to 

retain Windows on your system. However, you’ll need to know how to install the new 

drive or find someone to do it for you (although step-by-step guides can be found on the 

Web—just search using Google or another search engine). In addition, if your PC is less 

than 12 months old, there is a possibility that you’ll invalidate your warranty by opening 

up your PC.

If you have an old PC lying around, you might also consider installing Ubuntu on it, at 

least until you’re sure that you want to run it on your main PC. 

VIRTUALIZATION

If you don’t want to repartition your disk or add another disk drive, there’s another way you can run 

Ubuntu under Windows: using virtualization software. 

Put simply, virtualization software lets you run a “computer within a computer” (or, in fact, several 

computers within a computer!). It does this by cleverly sharing system resources between the real 

computer and the one that’s being virtualized. 

When the virtualization software is run, the virtual computer appears in a program window. A BIOS-

like startup screen appears, just like on a real computer, and then the virtual hard disk (usually a file on 

the main hard disk) is booted. An operating system may then be installed onto the virtual hard disk or, 

alternatively, it’s possible to download entire virtual machines from various sites, for which the hard 

work of installing the operating system has been done for you! 

There are a wide variety of virtualization software packages available. Perhaps the most popular are 

those offered by VMWare, including VMWare Server and VMWare Player. Although proprietary software, 

both of these two products are entirely free of charge and can be downloaded from www.vmware.com. 

Another version of VMWare, called Workstation, which is available for a charge, is also highly praised by 

many. You might investigate Microsoft Virtual PC 2004 too, which is also free of charge and can be 

downloaded from www.microsoft.com/windows/virtualpc/default.mspx. 

You can also obtain open-source renditions of virtualization software, such as QEMU (http://

fabrice.bellard.free.fr/qemu), although also worth downloading is QEMU Manager, which 

provides a GUI-based configuration front end for QEMU: see www.davereyn.co.uk/download.htm. 

Using a virtualized computer is useful for testing software but, obviously, the experience isn’t 

seamless. Operating systems running within virtual computers tend to operate more slowly compared to 

running natively on a computer, and the virtualized hardware is often very simple (you are usually unable 

to access your computer’s 3D graphics hardware, for example). Setting up a virtual computer can also 

be difficult for those who are new to it. 

One final note: virtualization software doesn’t just run on Windows. You can download several virtu-

alization software packages for Ubuntu, which means you could install and run Windows within a virtual 

machine running on Ubuntu! QEMU, mentioned previously, runs on Ubuntu, as does Xen: www.

xensource.com/products/downloads. 
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Backing Up Your Data
Whichever route you decide to take when installing Ubuntu, you should back up the data 

currently on your computer beforehand. Possibly the easiest way of doing this is to burn 

the data to CD-R/RW discs using a program like Nero and a CD-R/RW or DVD+-R/RW 

drive.

If you take the coexistence route, installing Ubuntu alongside Windows, backing up 

your data should be done for insurance purposes. Although the people behind Ubuntu 

test all their software thoroughly and rely on community reporting of bugs, there’s always 

the chance that something will go wrong. Repartitioning a hard disk is a major operation 

and carries with it the potential for data loss.

If you intend to erase the hard disk when installing Ubuntu (thereby removing Windows), 

you can back up your data and then import it into Ubuntu.

Table 4-1 shows a list of common personal data file types, their file extensions, where 

they can be typically found on a Windows system, and notes on importing the data into 

Ubuntu. Note that earlier versions of Windows (95, 98, and Me) may differ when it comes 

to data storage locations.

Table 4-1. Data That Should Be Backed Up

Type of 
File

File 
Extensions

Typical 
Location (Vista)

Typical 
Location (XP)

Notes

Office files .doc, .xls, 
.ppt, .pdf, 
etc.

\Users\<username>\
Documents

\Documents and 
Settings\
<username>\
My Documents

Microsoft Office files can be 
opened, edited, and saved 
under Ubuntu using the 
OpenOffice.org suite. PDF doc-
uments can be viewed with the 
Evince program.

E-mail files N/A N/A N/A The Evolution mail client used 
by Ubuntu cannot import 
data directly from Microsoft 
Outlook or Outlook Express. 
However, there is a convoluted 
but effective workaround, 
which is described in the next 
section. 

Digital 
images

.jpg, .bmp, 

.tif, .png, 

.gif, etc.

\Users\<username>\
Documents\Pictures

\Documents and 
Settings\
<username>\
My Pictures

Ubuntu includes a variety of 
programs to both view and edit 
image files.

Multimedia 
files

.mp3, .mpg, 

.avi, .wma, 
etc.

Various within 
Documents

Various within 
My Documents

With some additional down-
loads, discussed in Chapter 18, 
programs under Ubuntu can 
play MP3 music files and most 
movie file formats. 
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Backing Up E-Mail Files

Microsoft e-mail cannot be easily imported into Ubuntu. Most e-mail programs use the 

MBOX format, and this is true of Ubuntu as well as programs created by the Mozilla Foun-

dation (the organization behind the Firefox web browser). However, Microsoft uses its own 

DBX file format for Outlook Express and PST format for Outlook.

As a workaround, you can download and install the free Mozilla Thunderbird e-mail 

client (available from www.mozilla.com/en-US/thunderbird) on your Windows system. In 

Thunderbird, select Tools ➤ Import to import your messages from Outlook, Outlook 

Express, or even the popular Eudora mail client. You will then be able to back up Thunder-

bird’s mail files and import them into Evolution under Ubuntu, as described in Chapter 27. 

To find where the mail files are stored, in Thunderbird, select Tools ➤ Account 

Settings, and then look in the Local Directory box. Back up each file that corresponds to a 

folder within your mail program (for example, Inbox, Sent, and so on). Note that you only 

Internet Ex-
plorer 
Favorites

None \Users\<username>\
Favorites

\Documents 
and Settings\
<username>\
Favorites

Your Favorites list cannot be 
imported into Ubuntu, but the 
individual files can be opened 
in a text editor in order to view 
their URLs, which can then be 
opened in the Ubuntu web 
browser.

Mozilla 
Firefox 
Bookmarks

.html N/A N/A If you use Mozilla Firefox 
under Windows, you can man-
ually export your bookmarks 
for import under Firefox when 
Ubuntu is installed. Click Book-
marks ➤ Organize bookmarks, 
and click File ➤ Export in the 
window that appears. To import 
the bookmarks into Ubuntu’s 
version of Firefox, repeat the 
steps, but click File ➤ Import 
instead, and then locate the 
.html file you saved. 

Miscellaneous 
Internet files

Various Various Various You might also want to back up 
web site archives or instant 
messenger chat logs, although 
hidden data such as cookies 
cannot be imported.

Table 4-1. Data That Should Be Backed Up (Continued)

Type of 
File

File 
Extensions

Typical 
Location (Vista)

Typical 
Location (XP)

Notes
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need to back up the files without file extensions. You can ignore the .sdb folders as well as 

the .msf files.

■Tip  To quickly go to the location of the Thunderbird e-mail files under Windows, copy the address in the 

Local Directory text box. Then, under Windows XP, click Start ➤ Run, paste the address straight into the Open 

box, and click OK. Under Windows Vista, paste the address into the Start Search text box, and press Enter. 

Making Notes

When you’re backing up data, a pencil and paper come in handy, too. You should write 

down any important usernames and passwords, such as those for your e-mail account 

and other online services. You might want to write down the phone number of your dial-up 

connection, for example, or your DSL/cable modem technical settings. Figure 4-3 shows 

an example of some information you might want to record. 

In addition, don’t forget to jot down essential technical details, such as your IP address 

if you are part of a network of computers using static addresses (this will usually be relevant 

only if you work in an office environment).

■Tip  If you’ve forgotten any passwords, several freeware/shareware applications are able to “decode” the 

asterisks that obscure Windows passwords and show what’s beneath them. A good example is Asterisk 

Password Reveal, which you can download from www.paqtool.com/product/pass/pass_001.htm. 

Shareware sites like www.download.com offer similar applications.

Note that you don’t need to write down information such as hardware interrupt (IRQ) 

or memory addresses, because hardware is configured automatically by Ubuntu. However, it 

might be worth making a note of the make and model of some items of internal hardware, 

such as your graphics card, modem (dial-up, DSL, or cable), and sound card. This will 

help if Ubuntu is unable to automatically detect your hardware, although such a situation 

is fairly unlikely to arise. Under Windows Vista, you can find out this information by clicking 

the Start button and right-clicking Computer. Click Properties in the menu that appears, and 

click the Device Manager link on the left of the window that appears. Under Windows XP, 

right-click My Computer on the desktop (or on your Start menu), select Properties, and 

click the Hardware tab. Then click the Device Manager button. 

Instead of writing everything down, you might consider taking a screenshot by pressing 

the Print Scr button and using your favorite image editor to print it.
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Figure 4-3. Don’t forget to back up “hidden” data, such as ISP dial-up phone numbers.

■Tip  Ubuntu works with a wide variety of hardware, and in most cases, it will automatically detect your 

system components. If you’re in any doubt, you can consult the forums at http://ubuntuforums.org, in 

particular, the Hardware Help forums under the Main Support Categories heading. You might also consider 

subscribing to one or more of the Ubuntu mailing lists at https://lists.ubuntu.com. Remember that an 

important element of Ubuntu is its community of users, many of whom will be very willing to answer any 

questions you might have!

Once you’re certain that all your data is backed up, you can move on to the next chapter, 

which provides a step-by-step guide to installing the operating system.
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Summary
The aim of this chapter has been to prepare both you and your computer for the installation 

of Ubuntu. We’ve looked at how your hard disk will be partitioned prior to installation and 

the preparations you should make to ensure your hard disk has sufficient free space. You 

also learned about the types of files you might choose to back up, in addition to vital 

details you should record, such as usernames and passwords for your online accounts.

In the next chapter, we move on to a full description of the Ubuntu installation procedure. 

The chapter guides you through getting Ubuntu onto your computer.


